Issues with one server causing slowdowns
Incident Report for Serenytics
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 08:57 CET
Investigating
We are currently investigating this issue.
Posted Feb 10, 2020 - 08:40 CET
This incident affected: Dashboards for Viewers.